Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-3096

Studio: Installing iOS Simulator 5.0 & 5.1, using xcode 4.5.1 does not provide option for iOS SDK 5.0 & 5.1 in run configurations

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Invalid
    • Affects Version/s: Titanium Studio 3.0.0
    • Fix Version/s: None
    • Component/s: iOS
    • Environment:

      OS: Mountain Lion OSX 10.8.2
      XCode: 4.5.1
      Titanium Studio: 3.0.1.201212181159
      Titanium SDK: 3.0.0.GA

      Description

      Steps To Reproduce:
      1. Create a default Titanium project.
      2. Go to its Run Configurations and observe Options appearing in drop-down "Simulator version" and "iOS SDK" [Observe only 6.0 appears in both dropdown]
      3. Open Xcode 4.5.1, and using preferences>download; Download iOS simulator 5.0 and 5.1
      4. Now observe run configurations of the default app created. Observe iOS simulator version has 5.0 and 5.1 as options but iOS SDK contains on 6.0 as option.
      Refer attachment

      Actual:
      In Run config, "simulator version" has 5.0 and 5.1 as options but iOS SDK contains on 6.0 as option.
      Expected:
      iOS SDK 5.0 and 5.1 should also appear in iOS SDK dropdown.

        Attachments

          Activity

            People

            • Assignee:
              nle Nam Le (Inactive)
              Reporter:
              prastogi Pragya Rastogi
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: