Titanium Studio
  1. Titanium Studio
  2. TISTUD-2966

Disparity in CLI reports from Windows and Ubuntu to Mac OS

    Details

      Description

      When checking the diagnostic print out, Titanium Studio, build: 3.1.0.201212031735 now shows if the new CLI is being used. I see "Titanium CLI Enabled: true" for Windows and Ubuntu, and "Titanium CLI Enabled: false" for Mac with default flag settings.

      This functionality does not exist in Titanium Studio 3.0.0 or 3.0.1.

      Steps to reproduce:
      1. On Mac OS start Titanium Studio.
      2. Run the Diagnostic test (Help > Titanium Studio > Run Diagnostic Test...)
      3. On Windows start Titanium Studio.
      4. Run the Diagnostic test (Help > Titanium Studio > Run Diagnostic Test...)
      5. Compare the results.

      Expected Result:
      Results for CLI usage with default flag settings should match.

      Actual Result:
      Windows (and Ubuntu) reads "Titanium CLI Enabled: true"
      Mac OS reads "Titanium CLI Enabled: false"

        Issue Links

          Activity

          Hide
          Dustin Hyde added a comment -

          This is interfering with testing, the user should not have to clean the workspace to recognize the CLI functionality.

          Show
          Dustin Hyde added a comment - This is interfering with testing, the user should not have to clean the workspace to recognize the CLI functionality.
          Hide
          Natalie Huynh added a comment -

          Tamila, Olga and I all encountered this problem. Being that we can't tell when CLI is being used during build time we need to get this fixed. The only way to tell is by going to the log file to see whether its the new CLI or the old python scripts.

          Show
          Natalie Huynh added a comment - Tamila, Olga and I all encountered this problem. Being that we can't tell when CLI is being used during build time we need to get this fixed. The only way to tell is by going to the log file to see whether its the new CLI or the old python scripts.
          Hide
          Michael Xia (Inactive) added a comment -

          Pushed the fix to all three branches so that CLI will always be used by default on existing workspaces. The addition to diagnostic log on CLI enablement is tracked in TISTUD-2972.

          Show
          Michael Xia (Inactive) added a comment - Pushed the fix to all three branches so that CLI will always be used by default on existing workspaces. The addition to diagnostic log on CLI enablement is tracked in TISTUD-2972 .
          Hide
          Clayton Headley (Inactive) added a comment -

          Verified fixed in Mac OS 10.8.2, Windows 8, and Ubuntu 12.04 using Titanium Studio, build: 3.1.0.201212041934. Closing ticket.

          Show
          Clayton Headley (Inactive) added a comment - Verified fixed in Mac OS 10.8.2, Windows 8, and Ubuntu 12.04 using Titanium Studio, build: 3.1.0.201212041934. Closing ticket.

            People

            • Assignee:
              Michael Xia (Inactive)
              Reporter:
              Clayton Headley (Inactive)
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: