Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-2898

(Windows) Cannot set Android SDK Home in Titanium Settings pane

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Titanium Studio 3.0.0
    • Component/s: None
    • Environment:
    • Story Points:
      5

      Description

      The error can be seen in the attached error-1.jpg. Basically it's "Unknown command: --no-banner", then "Unexpected character (A) at position 0".

      This appears to be very similar to TISTUD-778.

      The only error in the log is this: http://pastie.org/5454102. I think I have fairly aggressive logging turned on (see troubleshooting_settings.jpg attached here), yet I cannot even see what command is being executed that is resulting in this error.

      I confirmed the following:

      • I can successfully run android list targets from a command prompt.
      • I have no ANDROID_SDK environment variable set.
      • I can successfully run python c:\Users\bill\AppData\Roaming\Titanium\mobilesdk\win32\3.0.0\android\avd.py c:\Users\bill\android\android-sdk from a command prompt and see the expected results.

      I also completely uninstalled Ti Studio, completely removed my workspace folder, then re-downloaded the Studio RC and created a new workspace. Still the same error when trying to set my Android SDK Home.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mxia Michael Xia
                Reporter:
                billdawson Bill Dawson
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: