Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-270

HTML content assist stops working with inline children elements

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Fixed
    • Affects Version/s: Titanium Studio M3 (Public beta 1)
    • Fix Version/s: Titanium Studio M4 (RC 1)
    • Component/s: None
    • Environment:

      Windows Vista 64bit
      Titanium Studio, build: 1.0.0.201104041321
      (c) Copyright 2011 by Appcelerator, Inc. All rights reserved.

      Build date: 04 April 2011, 13:23:30

      Description

      There's still a strange content assist bug present. It's only activated when you're using strong*inline*strong children elements. This means you don't use Enter or any other indentation options for these elements. Try the following content-assist situations:

       
      <!DOCTYPE html>
      <html lang="nl">
      <head>
      </head>
      <body>
        <p>
      </body>
      </html> 

      You'll see that <p> is automatically completed with the </p> closing tag, as it should be.

      However in this case:

       
      <!DOCTYPE html>
      <html lang="nl">
      <head>
      </head>
      <body>
        <p><span></p>
      </body>
      </html> 

      When you're adding the <span> element like this, it does strong*not*strong get completed in the usual way. You have to press Enter first and then move the cursor one space to the right.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cwilliams Christopher Williams
                Reporter:
                martijnvant Martin Koolen
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: