Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-2595

Fail to run iOS Simulator on a Titanium project

    Details

      Description

      1. Create a Titanium project using the default template; the SDK could be either 2.1.3 or 3.0.0;
      2. Do Run > iPad Simulator.

      The iPad simulator will launch but then exit soon after. Here is the console log:

      [INFO] One moment, building ...
      [INFO] Titanium SDK version: 2.1.3 (10/02/12 16:16 15997d0)
      [INFO] iPhone Device family: universal
      [INFO] iPhone SDK version: 6.0
      [INFO] iPhone simulated device: ipad
      [INFO] Performing full rebuild. This will take a little bit. Hold tight...
      [INFO] Minimum iOS version: 4.3 Linked iOS Version 6.0
      [INFO] Performing clean build
      [INFO] Launching application in Simulator
      [INFO] Launched application in Simulator (164.85 seconds)
      [INFO] Application has exited from Simulator
      

      Here is the Studio log:

       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:57:01.710
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/killall" "-2" "iPhone Simulator"
      Working directory: null
      Environment: null
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:57:01.909
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/killall" "-2" "iphonesim"
      Working directory: null
      Environment: null
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:57:01.934
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/killall" "-2" "ios-sim"
      Working directory: null
      Environment: null
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:57:01.974
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Searching for python in PATH locations: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin, /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin, /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin, /usr/bin, /bin, /usr/sbin, /sbin, /usr/local/bin, /usr/local/git/bin, /usr/local/MacGPG2/bin, /Applications/android-sdk-mac_86/tools/
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:57:02.061
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Found executable on PATH: /usr/bin/python
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:57:02.062
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/python" "/Users/mxia/Library/Application Support/Titanium/mobilesdk/osx/2.1.3.GA/iphone/builder.py" "simulator" "6.0" "/Users/mxia/Documents/Titanium_Studio_Workspace/mobile_default" "mobile.test" "mobile_default" "universal" "ipad" ""
      Working directory: null
      Environment: {ANALYTICS_SOURCE=studio, APTANA_VERSION=3.0.0.1346448223, Apple_PubSub_Socket_Render=/tmp/launch-lEsUVm/Render, Apple_Ubiquity_Message=/tmp/launch-dwNXin/Apple_Ubiquity_Message, COMMAND_MODE=unix2003, DEVELOPER_DIR=/Applications/Xcode.app/Contents/Developer, HOME=/Users/mxia, JAVA_HOME=/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home, LANG=en_US.UTF-8, LOGNAME=mxia, PATH=/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/local/MacGPG2/bin:/Applications/android-sdk-mac_86/tools/, PWD=/Applications/Titanium Studio/TitaniumStudio.app/Contents/MacOS, SHELL=/bin/bash, SHLVL=1, SSH_AUTH_SOCK=/tmp/launch-Y6KhWl/Listeners, TMPDIR=/var/folders/f_/syd0yymx7d3cq5sp7wg3tshw0000gp/T/, USER=mxia, __CF_USER_TEXT_ENCODING=0x1F6:0:0, com.apple.java.jvmTask=JNI}
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:59:52.419
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/killall" "-2" "iPhone Simulator"
      Working directory: null
      Environment: null
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:59:52.649
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/killall" "-2" "iphonesim"
      Working directory: null
      Environment: null
       
      !ENTRY com.aptana.core 1 0 2012-10-21 14:59:52.799
      !MESSAGE (Build 3.0.0.201210201924) [INFO] com.aptana.core/debug/shell Running process:
      Process: "/usr/bin/killall" "-2" "ios-sim"
      Working directory: null
      Environment: null
      

      Look like we're killing all the iOS processes afterward. Running iPhone simulator shows the same behavior.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mxia Michael Xia
                Reporter:
                mxia Michael Xia
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: