Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-1964

Titanium Studio fails to launch after a sudden shutdown

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Needs more info
    • Affects Version/s: Titanium Studio 2.1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      Titanium Studio, build: 2.1.0.201206251749
      (c) Copyright 2012 by Appcelerator, Inc. All rights reserved.

      Build: jenkins-titanium-rcp-master-218 (origin/master)
      Date: 25 June 2012, 17:50:34

      Mac OS X v 10.7.4

      Description

      Problem

      At times ( possibly after an ungraceful shutdown ), Ti Studio fails to launch. It can take 10 or more tries to get it started.

      Here is the stack trace that follows:

       
      !SESSION 2012-07-11 08:26:40.445 -----------------------------------------------
      eclipse.buildId=unknown
      java.version=1.6.0_33
      java.vendor=Apple Inc.
      BootLoader constants: OS=macosx, ARCH=x86, WS=cocoa, NL=en_US
      Framework arguments: -keyring /Users/eseilnacht/.eclipse_keyring -showlocation
      Command-line arguments: -os macosx -ws cocoa -arch x86 -keyring /Users/eseilnacht/.eclipse_keyring -consoleLog -showlocation
       
      !ENTRY org.eclipse.core.resources 2 10035 2012-07-11 08:26:41.593
      !MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
       
      !ENTRY org.eclipse.core.net 1 0 2012-07-11 08:26:41.982
      !MESSAGE System property http.nonProxyHosts has been set to local|.local|169.254/16|.169.254/16 by an external source. This value will be overwritten using the values from the preferences
       
      !ENTRY org.eclipse.osgi 4 0 2012-07-11 08:26:42.593
      !MESSAGE An error occurred while automatically activating bundle org.eclipse.team.svn.ui (711).
      !STACK 0
      org.osgi.framework.BundleException: Exception in org.eclipse.team.svn.ui.SVNTeamUIPlugin.start() of bundle org.eclipse.team.svn.ui.
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
      at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:381)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:299)
      at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:440)
      at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:268)
      at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
      at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:463)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
      at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:400)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:476)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
      at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
      at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
      at org.eclipse.osgi.internal.loader.BundleLoader.loadClass(BundleLoader.java:345)
      at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass(BundleHost.java:229)
      at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass(AbstractBundle.java:1207)
      at org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecutableExtension(RegistryStrategyOSGI.java:174)
      at org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExtension(ExtensionRegistry.java:905)
      at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension(ConfigurationElement.java:243)
      at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension(ConfigurationElementHandle.java:55)
      at org.eclipse.team.svn.core.extension.CoreExtensionsManager.loadExtensions(CoreExtensionsManager.java:195)
      at org.eclipse.team.svn.core.extension.CoreExtensionsManager.loadCoreExtensions(CoreExtensionsManager.java:180)
      at org.eclipse.team.svn.core.extension.CoreExtensionsManager.instance(CoreExtensionsManager.java:61)
      at org.eclipse.team.svn.core.SVNTeamPlugin.getOptionProvider(SVNTeamPlugin.java:99)
      at org.eclipse.team.svn.core.utility.ProgressMonitorUtility.doTaskScheduled(ProgressMonitorUtility.java:50)
      at org.eclipse.team.svn.core.svnstorage.SVNRemoteStorage.fireResourceStatesChangedEvent(SVNRemoteStorage.java:174)
      at org.eclipse.team.svn.core.ResourceChangeListener$1.runImpl(ResourceChangeListener.java:98)
      at org.eclipse.team.svn.core.operation.AbstractActionOperation.run(AbstractActionOperation.java:81)
      at org.eclipse.team.svn.core.operation.LoggedOperation.run(LoggedOperation.java:39)
      at org.eclipse.team.svn.core.utility.ProgressMonitorUtility.doTask(ProgressMonitorUtility.java:104)
      at org.eclipse.team.svn.core.utility.ProgressMonitorUtility.doTaskExternal(ProgressMonitorUtility.java:90)
      at org.eclipse.team.svn.core.utility.ProgressMonitorUtility$1$1.run(ProgressMonitorUtility.java:60)
      at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:2344)
      at org.eclipse.team.svn.core.utility.ProgressMonitorUtility$1.run(ProgressMonitorUtility.java:58)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: java.lang.ExceptionInInitializerError
      at org.eclipse.team.svn.ui.preferences.SVNTeamPreferences.getConsoleRGB(SVNTeamPreferences.java:830)
      at org.eclipse.team.svn.ui.console.SVNConsole.loadPreferences(SVNConsole.java:162)
      at org.eclipse.team.svn.
      
      

      The following steps were provided to reproduce (I could reproduce it though):

      1. Launch Studio
      2. Force shutdown the computer
      3. Reboot the computer
      4. Relaunch Studio

        Attachments

          Activity

            People

            • Assignee:
              ingo Ingo Muschenetz
              Reporter:
              vjoshi Varun Joshi
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: