Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-1551

CLONE - Unable to correctly parse git version

    Details

    • Story Points:
      5

      Description

      Found in Eric's log file. I though this was a duplicate of another ticket, but I can't find the first version.

      !ENTRY com.aptana.git.core 4 0 2012-03-30 11:52:03.083
      !MESSAGE (Build 3.0.0.1332346356) [ERROR] com.aptana.git.core/debug Unable to correctly parse git version 1.7.7.5 (Apple Git-26)
      !STACK 0
      java.lang.IllegalArgumentException: invalid qualifier: 5 (Apple Git-26)
      at org.osgi.framework.Version.validate(Version.java:195)
      at org.osgi.framework.Version.<init>(Version.java:161)
      at org.osgi.framework.Version.parseVersion(Version.java:225)
      at com.aptana.git.core.model.GitExecutable.version(GitExecutable.java:399)
      at com.aptana.git.core.model.GitExecutable.clone(GitExecutable.java:431)
      at com.aptana.git.ui.CloneJob.run(CloneJob.java:86)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cwilliams Christopher Williams
                Reporter:
                ingo Ingo Muschenetz
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: