Uploaded image for project: 'Appcelerator Studio'
  1. Appcelerator Studio
  2. TISTUD-1272

iOS: Xcode 4.3 - Dashboard tooltip for iOS SDK, showing supported Xcode versions, needs to be updated

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: Dashboard
    • Environment:

      Mac OS: 10.7.3
      Titanium Studio: 1.0.9.201202141208
      SDK: 1.8.2 GA
      Xcode 4.3 developer preview (4E109)

    • Story Points:
      8

      Description

      Description:
      While testing Xcode 4.3, and prior to setting the Xcode-select to point to the correct location, the iOS SDK icon in the dashboard shows setup is needed. When hovering over the icon, a tooltip appears. WHile mostly accurate, some details need updating. Specifically, Xcode 3.2.6 is not supported but is mentioned on the tooltip. Another is the mention of Xcode 4.0+. Currently we do not fully support 4.3, so based on the schedule for this, it can remain as-is or must be limited to pre-4.3 versions.

      Steps to reproduce:
      1) Install and launch studio
      2) Open the dashboard and navigate to the sdk setup page
      3) Hover over the iOS SDK button

      Result:
      The tooltip comes up and has some inconsistencies

      Expected:
      The tooltip accurately describes the supported Xcode versions required

        Attachments

          Activity

            People

            • Assignee:
              ingo Ingo Muschenetz
              Reporter:
              emerriman Eric Merriman
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: