Uploaded image for project: 'Titanium Mobile'
  1. Titanium Mobile
  2. TIMOB-8414

Android: Debugger - On V8, JNIUtil error messages appear when debugging with breakpoints

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 2.0.0
    • Fix Version/s: Release 2.1.0, Sprint 2012-07
    • Component/s: Android
    • Environment:

      SDK build: 2.0.0.v20120328183230
      Runtime: v8
      Titanium Studio, build: 2.0.0.201203290942
      Device: Android Emulator 2.2
      OS: Snow Leopard (10.6.8), Linux (11.10), Window 7

    • Story Points:
      0.5

      Description

      Steps to reproduce:
      1. Unzip and import attachment
      2. From https://wiki.appcelerator.org/display/tp/Debugger+Test+Plan, execute test case 1013

      Actual: After step 9, the following error messages appear:

      E/JNIUtil (  398): !!! Unable to convert unknown Java object class 'org.appcelerator.kroll.KrollRuntime$1' to Js value !!!
      E/JNIUtil (  398): !!! Unable to convert unknown Java object class 'org.appcelerator.kroll.KrollRuntime$1' to Js value !!!
      E/JNIUtil (  398): !!! Unable to convert unknown Java object class 'org.appcelerator.kroll.KrollRuntime$1' to Js value !!!
      

      Even though these error messages appear, it does not seem to affect the debugger i.e. the debugger does not terminate and I am still getting expected results from the debugger test plan.

      Expected: Error messages should not appear.

      Note:

      • The error messages do not appear in 1.8.2
      • Only tested in v8. Did not test in rhino.
      • The error messages appear only when using breakpoints.

        Activity

        joshroesslein Josh Roesslein added a comment -

        The issue is actually appears outside of the debugger test case as well.
        Here's another test case that replicates the error messages in the log:

        Expected: There should be no JNIUtil error messages.

         
        var win = Ti.UI.createWindow();
         
        var view = Ti.UI.createView();
        win.add(view);
         
        Ti.API.info("Center => " + view.center);
         
        win.open();
        

        joshroesslein Josh Roesslein added a comment -

        Submitted PR #1920 to resolve issue.

        mpettiford Michael Pettiford added a comment -

        Closing issue

        Tested with Ti Studio build 2.1.0.201206200844
        Ti Mobile SDK 2.1.0.v20120619172256 hash rd3a84b13
        OSX Lion 10.7.3
        Android Emulator 2.2

        The expected behavior is shown


          People

          • Assignee:
            joshroesslein Josh Roesslein
            Reporter:
            wluu Wilson Luu
          • Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Poker Sessions

                This issue is currently not assigned to any Poker Session.