Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-8056

Android: Error when resolving modules in Linux

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 1.8.0.1, Release 2.0.0, Release 1.8.1, Release 1.8.2
    • Fix Version/s: Release 2.1.0, Sprint 2012-07
    • Component/s: Android
    • Labels:
    • Environment:

      OS: Linux Ubuntu 10.10 2.6.38-8-generic-pae #42-Ubuntu SMP i686
      >GNU/Linux

      Description

      Error Message:

      Location: [353,8]ti:/module.js
      Message: Uncaught Error: Requested module not found: com.*.* (module could be anything)
      Source: throw new Error("Requested module not found: " + request);
      

      Description:
      Previously working with Titanium mobile Linux SDK 1.7.6, able to build the project, build the modules, use the modules, and run the application without any problems. Any mobile sdk greater than or equal to 1.8.0 receiving the above runtime error when launching the application. Tested Android Google API 13, Android Google API 15, and an android device running 4.0.2. Also ported all modules for use with 1.8.0.1 or greater following the information in this guide: https://wiki.appcelerator.org/display/guides/Android+Module+Porting+Guide+for+1.8.0.1. Every time the project build runs successfully without errors, just not able to run it.

      This project works fine on OS X, using the same code.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ayeung Allen Yeung
                Reporter:
                aleard Alan Leard
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-12448
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration