Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-7680

iOS: iTunes_sync.scpt - Error reported when iTunes sync script launched during build with iPod connected to iTunes

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: Release 1.8.2
    • Fix Version/s: Release 3.2.0
    • Component/s: CLI, iOS, Tooling
    • Labels:
    • Environment:

      Mac OS 10.7.2
      iPod 4th gen (4.3.3)
      SDK: 1.8.2.v20120214163156
      Titanium Studio, build: 1.0.9.201202131024

      Description

      Description:
      While building some test projects, Studio reported the following:
      [INFO] Performing clean build
      [INFO] Installing application in iTunes ... one moment
      [DEBUG] executing command: /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/PackageApplication /Users/eric/Documents/fromGit/titanium_mobile_tests_internal/FeatureTest/OrientationModes/all/build/iphone/build/Debug-iphoneos/all.app
      /Users/eric/Library/Application Support/Titanium/mobilesdk/osx/1.8.2.v20120214163156/iphone/itunes_sync.scpt: execution error: Can't make name of 3 into type Unicode text. (-1700)
      [INFO] iTunes sync initiated

      The build seemed to complete, and the application was placed in iTunes as expected.

      A quick check of the iTunes_sync.scpt shows a suspect line:
      log "The device " & name of n & " was unable to sync (" & errorStr & ":" & errorNumber & ")"

      When changing the line to include "name of source n", the error went away. (Kudos to Blain for the suggestion)

      Also, without the iPod hooked up, the error was not presented.

      Steps to reproduce:
      1) Create a sample project using Studio 1.0.9
      2) Attach an iPod for use in testing
      3) Build the project for device using SDK 1.8.2

      Result:
      Error reported in Studio

      Expected:
      No errors reported

      Note:
      This appears on the Q&A page as occurring as early as 1.7.1, so not marking as regression. Link:
      http://developer.appcelerator.com/question/122993/error-while-moving-app-to-ios-device

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ingo Ingo Muschenetz
                Reporter:
                emerriman Eric Merriman
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-12126
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration