Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-7552

Android: FastDev: Ti.include: blank include files fail to load and invalidates app

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: Release 1.8.0.1, Release 2.0.0, Release 1.8.2
    • Component/s: Android
    • Labels:
    • Environment:

      Description

      Ti.include files with no code content fail to load in FastDev and app behavior fails to continue.
      Regression. Works in 1.8.1 stable. Previously occurred in 1.8.0.1 stable.
      Occurs in 1.9.0 beta and 1.8.2 beta on all emulators in V8/Rhino except 4.0 w/V8. Log attached.

      Steps to Reproduce:

      1. Run IncludeTest.zip project on any Android emulator (except 4.0 w/V8).

      Expected Result:

      App should load properly and display an alert: 'Ti.include worked!'.

      Actual Result:

      App fails to load and generates runtime error.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                billdawson Bill Dawson
                Reporter:
                dhyde Dustin Hyde
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-12017
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration