Uploaded image for project: 'Titanium Mobile'
  1. Titanium Mobile
  2. TIMOB-6380

Android: tableView - v8/rhino - Scrolling large table results in out-of-memory error on tablets

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 1.8.0.1
    • Component/s: Android
    • Labels:
    • Environment:

      Galaxy Tab 10.1 (3.1), Xoom (3.2.1), SDK 1.8.0.1.v20111123202050, Titanium Studio, build: 1.0.7.201111282022

      Description

      Description:
      In KitchenSink, in Base UI>Views>Table Views>Performance, Scrolling the table rapidly results in an out of memory situation which can result in drastically degraded performance or a crash. Please see attached console output.

      Steps to reproduce:
      1) Install KS with 1.8.0.1
      2) Navigate to Base UI>Views>Table Views>Performance
      3) Scroll to the bottom of the table rapidly while monitoring console output

      Result:
      Out of memory, possible crash, possible drastic degradation of performance.

      Expected:
      No reduction in performance.

      Note:
      Also occurs with 1.7.5 GA
      Not observed on phones, just on tabs

      1. crashLog
        11 kB
        Ping Wang
      2. scrollPerfCrash.txt
        64 kB
        Eric Merriman

        Issue Links

          Activity

          No builds found.
          emerriman Eric Merriman created issue -
          emerriman Eric Merriman added a comment -

          Seeing this with SDK 1.8.0.1.v20111214093905 on the LG Slate (v8), but not on the Xoom with rhino.

          wluu Wilson Luu made changes -
          Field Original Value New Value
          wluu Wilson Luu added a comment -

          Bug still occurs in 1.9.0.v20120118184633 (V8) on Galaxy Tab 10.1 (3.1)

          ngupta Neeraj Gupta made changes -
          Priority None [ 6 ] High [ 2 ]
          ngupta Neeraj Gupta made changes -
          Fix Version/s Sprint 2012-03 [ 12095 ]
          joshroesslein Josh Roesslein made changes -
          Assignee Marshall Culpepper [ mculpepper ] Josh Roesslein [ joshroesslein ]
          joshroesslein Josh Roesslein made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          joshroesslein Josh Roesslein added a comment -

          PR #1348 sent.

          Use className to reuse views when scrolling through items.

          pwang Ping Wang added a comment -

          Still can reproduce the crash on rhino with PR#1348 using Galaxy Tab 10.1 (3.1). The crash log "crashLog" is attached.

          pwang Ping Wang made changes -
          Attachment crashLog [ 25623 ]
          pwang Ping Wang made changes -
          Fix Version/s Release 1.9.0 [ 12593 ]
          opiecyrus Opie Cyrus made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          wluu Wilson Luu added a comment -

          Reopening bug. Bug still persists on:

          SDK build: 1.9.0.v20120207000134
          Runtime: V8, Rhino
          Titanium Studio, build: 1.0.8.201201262211
          Device: Galaxy Tab 10.1 (3.1)

          Note: Same error as the attached crashLog

          wluu Wilson Luu made changes -
          Resolution Fixed [ 1 ]
          Status Resolved [ 5 ] Reopened [ 4 ]
          joshroesslein Josh Roesslein added a comment -

          Wilson can you reproduce this crash consistently?
          I know during the PR process Ping produced it once, but it never surfaced again.

          opiecyrus Opie Cyrus made changes -
          ayeung Allen Yeung added a comment -

          Wilson - I was able to reproduce this in 1_8_X version of KS, but it looks like this is fixed in 1.9.0 version of KS. Could you try retesting this in KS version 1.9.0?

          wluu Wilson Luu added a comment - - edited

          Closing bug. Cannot reproduce bug on:

          SDK build: 1.9.0.v20120207171634
          Runtime: V8, Rhino
          Titanium Studio, build: 1.0.8.201201262211
          Devices: LG Slate (3.1), Galaxy Tab 10.1 (3.1)

          Note: Also used KS version 1.9.0

          wluu Wilson Luu made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          ngupta Neeraj Gupta made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          ngupta Neeraj Gupta made changes -
          Fix Version/s Release 1.8.2 [ 13070 ]
          ngupta Neeraj Gupta made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          nderzhak Nikolai Derzhak made changes -
          Workflow Titanium full [ 96619 ] Copy 12 of Titanium full [ 248073 ]
          nderzhak Nikolai Derzhak made changes -
          Workflow Copy 12 of Titanium full [ 248073 ] Copy 13 of Titanium full [ 292725 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open In Progress In Progress
          65d 2h 57m 1 Josh Roesslein 03/Feb/12 5:50 AM
          In Progress In Progress Resolved Resolved
          3d 9h 29m 1 Opie Cyrus 06/Feb/12 3:19 PM
          Resolved Resolved Reopened Reopened
          16h 33m 1 Wilson Luu 07/Feb/12 7:52 AM
          Closed Closed Reopened Reopened
          6d 4h 47m 1 Neeraj Gupta 14/Feb/12 3:27 PM
          Reopened Reopened Closed Closed
          1d 2h 48m 2 Neeraj Gupta 14/Feb/12 3:29 PM

            People

            • Assignee:
              joshroesslein Josh Roesslein
              Reporter:
              emerriman Eric Merriman
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Poker Sessions

                  This issue is currently not assigned to any Poker Session.