Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-6299

iOS: Ti.API.log does not log to console in the iOS simulator when passed a previously undefined error type as the first argument

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Cannot Reproduce
    • Affects Version/s: Release 1.7.2, Release 1.7.5, Release 1.8.0.1
    • Fix Version/s: None
    • Component/s: iOS
    • Labels:
    • Environment:

      OS: OS X Lion
      Studio: 1.0.7.201111221758
      SDK: 1.8.0.1.v20111123144258
      Devices Tested: all supported

      Description

      When Ti.API.log is called with two arguments (the first being a previously undefined custom error type, as opposed to: warn, error, etc.) using any iOS simulator results in no log output being printed to the console.

      Steps to Reproduce:

      1. Run this line in a new app:

      Ti.API.log("CUSTOM", "Log Message");
      

      Expected Result:
      [CUSTOM] Log Message < should print to the console.

      Actual Result:
      Nothing from the log function prints to the console.

      Note:
      Custom error messages using this function call work in all iOS devices.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mculpepper Marshall Culpepper
                Reporter:
                dhyde Dustin Hyde
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-5328
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration