Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-5967

Packaged apps failing verification, reporting "...icon not found under the top level app wrapper: iTunesArtwork"

    Details

      Description

      Description:
      I recently added an additional test case to my packaging testing. After packaging, I now "validate" the app with apple. Prior to 1.8.0 SDK, this test would pass using the same test project. As of 1.8.0, the test app fails validation with the error "Icon specified in the Info.plist not found under the top level app wrapper: iTunesArtwork".

      Steps to reproduce:
      1) Create a Studio project with all 7 possible apple icons present
      2) Be sure to remove the png extension from iTunesArtwork
      3) Package for distribution from Studio
      4) From the Xcode archive, select "validate"

      Result:
      Validation fails with error shown in attachment

      Expected result:
      Validation succeeds

        Attachments

          Activity

            People

            • Assignee:
              srahim Sabil Rahim
              Reporter:
              emerriman Eric Merriman
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-5069
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code