Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-5235

Project cannot reinstall after build folder is cleaned

    Details

      Description

      1) Create an Android project and run it in the emulator.
      2) After the project has successfully installed on the emulator, close the emulator.
      3) Clean the project (either through Project -> Clean... or by deleting the build files manually in the project file: Titanium Studio Workspace\<project name>\build\android)
      4) Run the project in the emulator again

      Expected: Project installs normally and autolaunches in emulator
      Actual: Project never reinstalls in emulator. If you look in Debug perspective, the Application Installer exit value is 1 instead of the expected 0

      Notes:

      • Happens regardless of Fastdev being on or off.
      • Reproducible in build 1.0.2.201107130739

      Workaround:
      Exit and relaunch TiStudio. Application will now properly install on emulator.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mculpepper Marshall Culpepper
                Reporter:
                avaghti Alan Vaghti
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-4431
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration