Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-508

cannot access org.appcelerator.titanium.TiRootActivity upon trying to deploy KitchenSink demo app on Android

    Details

      Description

      {html}<div><p>I cannot deploy the <em>KitchenSink</em> demo app on any form of
      Android emulator. I downloaded the<br>
      app via the download button (not git) which offered a zip or tar
      archive. The base directory<br>
      of the archive is:</p>
      <pre>
      <code>ls -l appcelerator-KitchenSink-4d0db58/
      total 32
      drwxr-xr-x 3 cwolf cwolf 102 Mar 2 00:49 0.8.1
      drwxr-xr-x 2 cwolf cwolf 68 Mar 2 00:48 0.9.x
      -rwxr-xr-x 1 cwolf cwolf 11485 Feb 26 09:39 LICENSE
      -rwxr-xr-x 1 cwolf cwolf 709 Feb 26 09:39 README.md</code>
      </pre>
      <p>I imported the project into the Titanium IDE and set the log
      filter to "debug" and pressed<br>
      "launch" it seems to always have a class-not-found upon compilation
      phase. The relavant log output is:</p>
      <pre>
      <code>[DEBUG] javac -classpath /opt/android-sdk/platforms/android-1.6/android.jar:/Library/Application Support/Titanium/mobilesdk/osx/0.9.3/android/titanium.jar -d /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/bin/classes -sourcepath /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/src /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/src/com/appcelerator/kitchensink/KitchensinkActivity.java /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/src/com/appcelerator/kitchensink/KitchensinkAppInfo.java /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/src/com/appcelerator/kitchensink/KitchensinkApplication.java /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/src/com/appcelerator/kitchensink/R.java
      [ERROR] javac /Users/cwolf/Desktop/Downloads/appcelerator-KitchenSink-4d0db58/0.8.1/KitchenSink/build/android/src/com/appcelerator/kitchensink/KitchensinkActivity.java:3: cannot access org.appcelerator.titanium.TiRootActivity</code>
      </pre>
      <p>I tried both the "0.9.x" and "0.8.1" version of the
      <em>KitchenSink</em> app and got the same error.<br>
      Next, I looked at the <em>javac</em> command line (above) to see
      what jars were being referenced and<br>
      looked in the <em>titanium.jar</em> and see the class that's
      reported not found is, in fact, in the jar:</p>
      <pre>
      <code>$ cd /Library/Application Support/Titanium/mobilesdk/osx/0.9.3/android
      $ jar tvf titanium.jar | grep TiRoot
      414 Mon Mar 01 20:14:56 EST 2010 org/appcelerator/titanium/TiRootActivity$TiActivityRef.class
      918 Mon Mar 01 20:14:56 EST 2010 org/appcelerator/titanium/TiRootActivity$1.class
      6043 Mon Mar 01 20:14:56 EST 2010 org/appcelerator/titanium/TiRootActivity.class</code>
      </pre>
      <p>I have MacOS 10.5.8. Java version <em>1.5.0_22</em> (apple). I
      tried using all Android SDK emulations,<br>
      1.5, 1.6 and 2.0 (it would be helpful if a "readme" in
      <em>KitchenSink</em> indicated which to use)</p></div>{html}

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ngupta Neeraj Gupta
                Reporter:
                chriswolf Chris Wolf
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-479
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration