Uploaded image for project: 'Titanium Mobile'
  1. Titanium Mobile
  2. TIMOB-4138

Android: ActivityIndicator still shows if it's hidden before it's shown

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 1.7.0
    • Fix Version/s: Release 1.7.0, Sprint 2011-20
    • Component/s: Android
    • Labels:
      None

      Activity

      No builds found.
      mculpepper Marshall Culpepper created issue -
      mculpepper Marshall Culpepper added a comment -

      You can reproduce this in KS / SmokeTest Views > ImageViews > Animated (the Activity Indicator never goes away)

      mculpepper Marshall Culpepper made changes -
      Field Original Value New Value
      issue.field.resolutiondate 2011-05-19 08:01:12.0 2011-05-19 08:01:12.805
      mculpepper Marshall Culpepper made changes -
      Status Open [ 1 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Marshall Culpepper 19/May/2011 7:42 AM PDT
      View full commit
      don't show a dialog if it was hidden while waiting for the current
      activity to show TIMOB-4138
      Titanium Mobile
      1_7_X
      78ad07d71e1cbaa89fd83e7eb4eea0c59c01196b git-service
      Marshall Culpepper 19/May/2011 7:45 AM PDT
      View full commit
      don't show a dialog if it was hidden while waiting for the current
      activity to show TIMOB-4138
      Titanium Mobile
      master
      3f150980de120f7fa0469835f24d023122af6d36 git-service
      Goss Nuzzo-Jones 19/May/2011 10:16 AM PDT
      View full commit
      Merge branch 'master' into android-24-time

      * master: (53 commits)
        don't show a dialog if it was hidden while waiting for the current activity to show TIMOB-4138
        JS Compiler errors should err out rather than continue the build process. TIMOB-3313
        [TIMOB-3631] Never forget: -[NSMutableArray removeObjectAtIndex:] sends autorelease messages, not release.
        By having the webview's const string static, that avoids namespace conflicts later on. Booyah.
        TIMOB-4074 # Added placeholder class for JS functions to be a lighter replacement for KrollCallback (And not having retention issues) to sanity-check stored functions as well as allow one context to call another's function.
        TIMOB-4131 Resolved KitchenSink syntax errors, and warning according to TiStudio
        TIMOB-4070 #resolve Release the music picker when the popover is dismissed to allow re-entry into openMusicLibrary:
        Surround fastdev args that have spaces with fullquotes, but only for windows TIMOB-4082
        Fastdev script args with spaces need to be surrounded by quotes. TIMOB-4082
        generally handle dialogs better in situations that open a window asynchronously. exposed a new internal type TiDialogProxy, and a new helper function TiUIHelper.waitForCurrentActivity(..). this fixes the dialog "sandwiching" problem of ActivityIndicator, OptionDialog, the JS alert, and runtime error dialogs. TIMOB-3644
        [TIMOB-2011] Register evaluation errors with the bridge, so that they can be queried later (like during the window opening process.)
        Don't attempt to send deploy.json to sdcard if production mode or build_only. TIMOB-4133
        For compiled js files, replace dashes with underscores in file/class name. TIMOB-4043
        Removing documentation for Ti.Filesystem.File.append as it is an internal method in iOS and doesn't exist at all on Android.
        TIMOB-3385 #resolve Added more Drillbit test coverage to re-affirm that this issue is indeed fixed. Also, we kinda needed it too. ;-)
        Fixed type issues with Buffer. Removed duplicate setInt method from Ti.App.Properties
        [TIMOB-3533] - Remember TiProxies that are set as properties - When constructing tables, use the current page context if the execution context is not available yet to register sections/rows.
        TIMOB-3970 # Make sure the controller's proxy is set nil before being cast off.
        TIMOB-4025 removed the scaling factor that had been added for 1.5/1.6 devices. 2.1 Eris and Nexus One 2.3.4 work without it now
        [TIMOB-2317] Turns out that sometimes, multivalue properties don't have a label. Documentation makes it sound otherwise. Short-circuit label evaluation if there isn't one.
        ...
      Titanium Mobile
      master
      08c708690c38c8fd4dccfbe158c558a8ed6e80ec git-service
      emerriman Eric Merriman added a comment -

      Does not occur with Nexus S (2.3.2), Titanium Studio, build: 1.0.0.201105131803, Titanium SDK version: 1.7.X r3982f4e7. Closing.

      emerriman Eric Merriman made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      nderzhak Nikolai Derzhak made changes -
      Workflow Titanium full [ 73394 ] Copy 12 of Titanium full [ 246902 ]
      nderzhak Nikolai Derzhak made changes -
      Workflow Copy 12 of Titanium full [ 246902 ] Copy 13 of Titanium full [ 291554 ]
      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open Resolved Resolved
      20m 36s 1 Marshall Culpepper 19/May/11 1:01 AM
      Resolved Resolved Closed Closed
      5d 2h 36m 1 Eric Merriman 24/May/11 3:37 AM

        People

        • Assignee:
          mculpepper Marshall Culpepper
          Reporter:
          mculpepper Marshall Culpepper
        • Watchers:
          1 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development

              Poker Sessions

              This issue is currently not assigned to any Poker Session.

                Git Source Code