Titanium Mobile
  1. Titanium Mobile
  2. TIMOB-3331

Android: passwordMask does not disable autocomplete and dictionary

    Details

      Description

      {html}<div><p>In Android, a textField with passwordMask: true, still shows
      autocomplete and dictionary items.</p>
      <p>Step1: open KitchenSink<br>
      Step2: Controls > Text Field > The Rest<br>
      Step3: type something in text field to ensure that autocomplete
      shows up, if it does continue to step4<br>
      Step4: click 'Password Mask'<br>
      Step5: type a word in the text field<br>
      Step6: notice autocomplete showing up allowing you to see what is
      being typed in spite of the passwordMask<br>
      (See attached picture)</p>
      <h3>Tested On ###</h3>
      <p>TiSDK 1.6.0, Android 2.3.2, Nexus S</p>
      <h3>Associated Helpdesk Ticket</h3>
      <p><a href=
      "http://developer.appcelerator.com/helpdesk/view/76395">http://developer.appcelerator.com/helpdesk/view/76395</a></p></div>{html}

        Issue Links

          Activity

          No builds found.
          Jon Alter created issue -
          Jon Alter made changes -
          Field Original Value New Value
          Labels android defect reported-1.6.0 rplist
          Jon Alter made changes -
          Attachment android-password-autocomplete.png [ 18301 ]
          Jick Steen added a comment -
          {html}<div><p>Disable autocorrect and autocapitalization does also not work,
          see:<br>
          <a href=
          "http://developer.appcelerator.com/question/116625/android-kitchensink---disable-autocorrect-not-correct-working-when-password-mask-is-enabled">
          http://developer.appcelerator.com/question/116625/android-kitchensi...</a></p></div>{html}
          vetler (at gmail) added a comment -
          {html}<div><p>I've fixed this in a fork, and have requested a pull request on
          github: <a href=
          "https://github.com/appcelerator/titanium_mobile/pull/81">https://github.com/appcelerator/titanium_mobile/pull/81</a><br>
          Hopefully they'll pull the patch, and this should be fixed
          soon.</p>
          <p>If you're feeling adventurous, you can clone my fork and build
          it. </p></div>{html}
          Dennis Schneider added a comment -
          {html}<div><p>Hi Guys,</p>
          <p>please accept that pull request if it solves the problem. It's
          really annoying when users try to login and their password is saved
          in the dictionary. Many users are complaining about that.</p>
          <p>Thanks and kind regards,<br>
          Dennis</p></div>{html}
          Shish added a comment -
          {html}<div><p>I'm also getting complaints about this, users can't log in
          because their passwords are auto-completed with capital letters
          (Yeah, I know they can override the autocomplete, but <em>they</em>
          don't know that...)</p></div>{html}
          Don Thorp added a comment -
          {html}<div><p>I'm going to look at this, but have you guys tried setting
          <code>autocorrect : false</code> in the creation args of the text
          field? Just trying to narrow it down.</p></div>{html}
          Jon Alter added a comment -
          {html}<div><p>I have tried using autocorrect:false with the same result. Here
          is the textField I used for testing.<br></p>
          <pre>
          <code class=
          "javascript">var passwordField = Ti.UI.createTextField({ returnKeyType : Titanium.UI.RETURNKEY_DONE, enableReturnKey : true, hintText : 'Password', value : '', color : '#666', top : 50, width : '90%', passwordMask : true, autocorrect : false });</code>
          </pre></div>{html}
          Don Thorp made changes -
          Labels android defect reported-1.6.0 rplist android defect release-1.7.0 reported-1.6.0 rplist
          Don Thorp made changes -
          Fix Version/s Sprint 2011-13 [ 11248 ]
          Fix Version/s TBS [ 11258 ]
          Don Thorp added a comment -
          {html}<div><p>Slipping into 14, can't find a fix that doesn't break other
          features yet.</p></div>{html}
          vetler (at gmail) added a comment -
          {html}<div><p>If it breaks, why is this not commented on the pull request? I
          would be more than happy to fix it.<br>
          <a href=
          "https://github.com/appcelerator/titanium_mobile/pull/81">https://github.com/appcelerator/titanium_mobile/pull/81</a></p>
          <p>It should trigger if password masking is enabled, and I don't
          see any obvious reasons not to switch to
          InputType.TYPE_TEXT_VARIATION_PASSWORD.</p></div>{html}
          Don Thorp added a comment -
          {html}<div><p>I'm testing across emulators and devices other than 2.3. If I
          could tell you what to fix, I'd already have fixed it. It looks
          likes like the problem is 2.3 dependent on device. No worries just
          trying to work through all the combinations where the value gets
          set and unset.</p></div>{html}
          vetler (at gmail) added a comment -
          {html}<div><p>Interesting ... I couldn't reproduce the bug in the emulator,
          but showed up on my Samsung Galaxy S. Didn't try other Android
          versions in the emulator than the one I had set up though.<br>
          Is the bug reproducible in the Android emulator at all?</p></div>{html}
          Don Thorp added a comment -
          {html}<div><p>We tested on 2.2.2 and 2.3.1 with the patch and it seems to be
          ok due to the order of when the password mask is applied. Thanks
          @vetler for the patch. Sorry it took this long, but other
          variations I was testing with flags were having some issues. I'm
          not positive there won't be a side-effect if someone tries to
          switch a password field to another field, but that's not the normal
          use case.</p>
          <p><a href=
          "https://github.com/appcelerator/titanium_mobile/commit/bbe956c79e537faa51c191ef1af2a9892933a5a7">
          https://github.com/appcelerator/titanium_mobile/commit/bbe956c79e537faa51c191ef1af2a9892933a5a7</a></p></div>{html}
          Don Thorp made changes -
          Fix Version/s Sprint 2011-14 [ 11249 ]
          Fix Version/s Sprint 2011-13 [ 11248 ]
          Don Thorp made changes -
          Fix Version/s Sprint 2011-15 [ 11250 ]
          Fix Version/s Sprint 2011-14 [ 11249 ]
          Don Thorp made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed - in QA [ 9 ]
          vetler (at gmail) added a comment -
          {html}<div><p>Great, happy to help! </p></div>{html}
          Ralf Pfeiffer made changes -
          Customer yes
          Ralf Pfeiffer made changes -
          Fix Version/s Release 1.7.0 [ 11244 ]
          Nikolai Derzhak made changes -
          Workflow Titanium lite [ 67463 ] Titanium full [ 70976 ]
          Don Thorp made changes -
          Bill Dawson made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Resolution Fixed - in QA [ 9 ] Fixed [ 1 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          4s 1 Don Thorp 14/Apr/11 8:42 PM
          Resolved Resolved Closed Closed
          12d 9m 1 Bill Dawson 26/Apr/11 8:52 PM

            People

            • Assignee:
              Don Thorp
              Reporter:
              Jon Alter
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development