Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-28457

Android: Update module Kotlin language support to 1.5.x

    Details

    • Story Points:
      1

      Description

      Summary:
      Titanium currently supports Kotlin language v1.4.30 when building native modules for Android.
      We should update Kotlin to v1.5.x to support the language's newest features.
      https://kotlinlang.org/docs/whatsnew15.html

      To-Do:
      Update the Kotlin version in the following files...
      https://github.com/appcelerator/titanium_mobile/blob/master/android/build.gradle
      https://github.com/appcelerator/titanium_mobile/blob/master/android/templates/build/root.build.gradle

        Attachments

          Activity

            People

            • Assignee:
              jquick Joshua Quick
              Reporter:
              jquick Joshua Quick
              Reviewer:
              Gary Mathews
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Integration