Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-28343

CLI: Update minimum Node.js version to 12.13.0

    Details

    • Type: Story
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 10.0.0
    • Component/s: CLI
    • Labels:
      None
    • Story Points:
      5
    • Sprint:
      2021 Sprint 3, 2021 Sprint 4, 2021 Sprint 5, 2021 Sprint 6, 2021 Sprint 7, 2021 Sprint 8, 2021 Sprint 9

      Description

      With Node.js 10 reaching end of life on April 30th 2021 we should drop support for Node.js 10 in SDK 10 and pick a new minimum.

      We previously picked the first 10 LTS and that seems to be a fitting choice here again - 12.13.0 - as it is satisfactory for all products dependencies.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                eharris Ewan Harris
                Reporter:
                eharris Ewan Harris
                Reviewer:
                Christopher Williams
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Integration