Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-28263

Android: Change min supported version to Android 5.0 (API Level 21)

    Details

    • Story Points:
      3
    • Sprint:
      2021 Sprint 7

      Description

      Summary:
      For Titanium 10.0.0, we should change the min Android OS version supported...

      • From: Android 4.4 (API Level 19)
      • To: Android 5.0 (API Level 21)

      Reason:
      At the time of this writing, Android 4.4 is only 4% of the market according to Google Play.

      By dropping 4.4, we can remove backward compatibility code which handles...

      • Multidexing
      • Nested scrolling
      • Ripple drawables

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jquick Joshua Quick
                Reporter:
                jquick Joshua Quick
                Reviewer:
                Gary Mathews
                Tester:
                Samir Mohammed
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Integration