Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-27683

iOS: Error message not appropriate when building a project to device less than min-ios-version

    Details

    • Type: Bug
    • Status: Open
    • Priority: None
    • Resolution: Unresolved
    • Affects Version/s: Release 9.0.0
    • Fix Version/s: None
    • Component/s: iOS
    • Environment:

      Mac OS: 10.15.1
      SDK: 9.0.0.v20191212110250
      Appc CLI: 7.1.2
      JDK: 11.0.4
      Node: 10.16.3
      Studio: 6.0.0.201911251516
      Xcode: 11.2
      Device: iPad mini (v9.3.5)

      Description

      When we build a titanium project to an iOS device which has iOS version less than the min-ios-version supported by the titanium SDK an error message is shown during the build process. The message needs to be changed as it seems inappropriate.

      Steps to Reproduce:
      1. Build a titanium project using Ti SDK 9.x to an iOS 9 device. Note: the min ios version with sdk 9.0 is ios 10.

      Actual Result:
      Error is shown during the build. The error message states to use <min-ios-ver>9.0</min-ios-ver> to be able to build.

      [ERROR] :  This app does not support the device "Helium"
      The device is running iOS 9.3.5, however the app's the minimum iOS version is set to 10.0
      In order to install this app on this device, lower the <min-ios-ver> to 9.3 in the tiapp.xml:
      <ti:app xmlns:ti="http://ti.appcelerator.org">
          <ios>
              <min-ios-ver>9.3</min-ios-ver>
          </ios>
      </ti:app>
      

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ssekhri Satyam Sekhri
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Integration