Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-27393

CLI: module build gives misleading error message when passed in Android SDK build tools is not installed

    Details

    • Type: Improvement
    • Status: Open
    • Priority: None
    • Resolution: Unresolved
    • Affects Version/s: Release 8.2.0
    • Fix Version/s: None
    • Component/s: Android, CLI
    • Labels:
      None
    • Story Points:
      5

      Description

      Jenkins modules builds were mysteriously failing suddenly on a new build node. Turns out I no longer was installing Android SDK build tools 25.0.3 but out pipeline library to build native modules was specifying to use that version.

      The error message it displays in this case is misleading and partially incorrect. It indicates that Builds tools 25.0.3 is not installed (correct!), but then summaries the various tool components versions that are installed and states build tools 25.0.3. is currently installed there (incorrect!).

      Please see the screenshot for the exact error.

        Attachments

          Activity

            People

            • Assignee:
              emerriman Eric Merriman
              Reporter:
              cwilliams Christopher Williams
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Source Code