Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-27380

iOS: Selecting a video from PhotoGallery does not work properly in ios13.1 beta device

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Invalid
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: iOS
    • Labels:
    • Environment:

      8.1.1.GA, ios13.1 beta device

      Description

      Selecting a video from PhotoGallery does not work properly in ios13.1 beta device.The customer is facing this on latest sdk (ti sdk 8.1.1.GA). There is no problem for still images.There are no errors in the trace log.

      Test project: Click here to download or check attachment sections.

      Test steps:

      1) Download the project and integrate it via studio
      2) Add the following into tiapp.xml:

          <key>NSCameraUsageDescription</key>
              <string>To allow you to take photos of documents for uploading</string>
              <key>NSMicrophoneUsageDescription</key>
              <string>Can we use your microphone?</string>
              <key>NSPhotoLibraryAddUsageDescription</key>
              <string>To allow you to upload photos of documents</string>
              <key>NSPhotoLibraryUsageDescription</key>
              <string>To allow you to upload photos of documents</string>
      

      3)Run the project
      4) After run, will get two buttons
      Open camera:Click openCamera to shoot and use a video, provides success result.
      Open Photogallery:Clicking openPhotoGallery and selecting a video from the photo gallery will fail.

      Note: We tested this on ti sdk 8.1.1.GA and IOS ios12.3.1,iphone 5s v12.4
      and unable to reproduce the issue.Clicking openPhotoGallery and selecting a video from the photo gallery is working expected on our end. Check attachment section for the testing output (IMG_0076(1).jpg).

      Console logs:

      [INFO] :   Finished building the application in 31s 453ms
       
      [INFO] :   Installing app on device: Mostafizur Rahman’s iPhone
       
      [INFO] :   App successfully installed on device: Mostafizur Rahman’s iPhone
       
      [INFO] :   symbols: /Users/macbookpro/Documents/Appcelerator_Studio_Workspace/alloyTest/build/iphone/build/Products/Debug-iphoneos/alloyTest.app.dSYM
       
      Please manually launch the application
       
      [INFO] :   alloyTest 1.0 (Powered by Titanium 8.1.1.0148ee6e79)
       
      [INFO] :   Click openCamera to shoot and use a video, succeed.
       
      [INFO] :   Clicking openPhotoGallery and selecting a video from the photo gallery is also working.
      

        Attachments

        1. app.zip
          5.25 MB
        2. IMG_0076 (1).jpg
          IMG_0076 (1).jpg
          108 kB
        3. trace_log.rtf
          2.54 MB
        4. UNADJUSTEDNONRAW_thumb_2.jpg
          UNADJUSTEDNONRAW_thumb_2.jpg
          35 kB
        5. UNADJUSTEDNONRAW_thumb_3.jpg
          UNADJUSTEDNONRAW_thumb_3.jpg
          70 kB
        6. UNADJUSTEDNONRAW_thumb_4.jpg
          UNADJUSTEDNONRAW_thumb_4.jpg
          50 kB
        7. UNADJUSTEDNONRAW_thumb_5.jpg
          UNADJUSTEDNONRAW_thumb_5.jpg
          19 kB

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                rmitro Rakhi Mitro
              • Watchers:
                9 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Source Code