Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26950

Android: Compile with SDK version 29 (Android Q)

    Details

      Description

      Update "titanium_mobile/android" to compile for Android Q (ie: "compileSdkVersion" 29).

      This is needed in order to use the newest API Level 29 features so that we can work on the "Android Q" epic.

      Starting off, Titanium should not target API Level 29 by default until all Android Q breaking changes have been resolved. But we should allow the developer to opt-in to targeting API Level 29 to test the newest features/changes.

        Attachments

          Activity

            People

            • Assignee:
              gmathews Gary Mathews
              Reporter:
              jquick Joshua Quick
              Reviewer:
              Joshua Quick
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Integration