Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26736

Android: Incremental builds broken in SDK 8+

    Details

    • Type: Bug
    • Status: Open
    • Priority: None
    • Resolution: Unresolved
    • Affects Version/s: Release 8.0.0
    • Fix Version/s: None
    • Component/s: Android
    • Labels:
      None
    • Environment:

      8.0.0.v20190114160512

      Description

      When using SDK 8+, incremental builds on Android are broken. Output:

      [INFO]  Generating /Users/hans/Documents/dev/myapp/myapp-titanium/build/android/res/values/theme.xml
      [INFO]  Running AAPT: /Users/hans/Library/Android/sdk/build-tools/28.0.3/aapt "package" "-f" "-m" "-J" "/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/gen" "-M" "/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/AndroidManifest.xml" "-A" "/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/bin/assets" "-S" "/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/res" "-I" "/Users/hans/Library/Android/sdk/platforms/android-28/android.jar" "-F" "/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/bin/app.ap_" "--ignore-assets" "!.svn:!.git:!.ds_store:!*.scc:.*:!CVS:!thumbs.db:!picasa.ini:!*~" "--output-text-symbols" "/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/intermediates/bundles" "--no-version-vectors" "--auto-add-overlay" "--extra-packages" "ti.modules.titanium.ui:android.support.coreui:android.support.coreutils:android.support.exifinterface:android.support.fragment:android.support.graphics.drawable.animated:android.support.graphics.drawable:android.support.mediacompat:android.support.transition:android.support.v4:android.support.v7.appcompat:android.support.v7.recyclerview:android.support.compat:android.support.design:android.support.v7.cardview:com.google.android.gms:com.alcoapps.actionbarextras"
      [ERROR] Failed to package application:
      [ERROR]
      [ERROR] ERROR: asset directory '/Users/hans/Documents/dev/myapp/myapp-titanium/build/android/bin/assets' does not exist
      

      Cleaning the app fixes the issue, but is not ideal for our dev-ux. Our app is already shared with the team and can be viewed at any time.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              hknoechel Hans Knöchel
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-6832
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code