Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26435

Android: Update gradle to support JDK 11

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 7.4.1
    • Fix Version/s: Release 7.5.0
    • Component/s: Android
    • Labels:
      None
    • Sprint:
      2018 Sprint 20 SDK, 2018 Sprint 21

      Description

      When running an app with Java 11, the build fails:

      [ERROR] Failed to run dexer:
      [ERROR]
      [ERROR] FAILURE: Build failed with an exception.
      [ERROR]
      [ERROR] * What went wrong:
      [ERROR] Could not determine java version from '11'.
      [ERROR]
      [ERROR] * Try:
      [ERROR] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
      [ERROR]
      [ERROR] * Get more help at https://help.gradle.org
      

      The Java version check:

      $ java --version
      java 11 2018-09-25
      Java(TM) SE Runtime Environment 18.9 (build 11+28)
      Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11+28, mixed mode)
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                eharris Ewan Harris
                Reporter:
                hknoechel Hans Knöchel
                Reviewer:
                Joshua Quick
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Source Code