Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26413

iPhone XS Max showing launch-screen images for both iPhone XS Max and iPhone XR

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 7.4.0
    • Fix Version/s: Release 7.4.1
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      Titanium SDK 7.4.0.GA

      Description

      Hi there,

      when launching the iPhone XS Max simulator with enable-launch-screen-storyboard being false, there is two launch-screen images being showed shortly after another. You'll see the correct launch image (Default-Portrait-2688h@3x.png) first for a split second and then you'll see the one for the iPhone XR (Default-Portrait-1792h@2x.png) right after. This has been tested on the simulator and on portrait mode only.

      Steps to reproduce:
      1. Create a new alloy mobile app
      2. Comment out $.index.open(); in /app/controllers/index.js to only see the launch-screen
      3. In tiapp.xml set enable-launch-screen-storyboard to false
      4. In tiapp.xml set sdk-version to 7.4.0.GA
      5. Add the attached launch-images for iPhone XS Max and iPhone XR to /app/assets/iphone
      6. Launch the App with the iPhone XR simulator; you'll see the red launch-screen image (Default-Portrait-1792h@2x) as expected
      7. Launch the app with the iPhone XS Max simulator; you'll see the green launch-screen image (Default-Portrait-2688h@3x.png) as expected, but then after a split second it blends over to the red launch-screen image (Default-Portrait-1792h@2x.png)

      Expected behaviour:
      Launching the app with the iPhone XS Max simulator will only show the green launch-screen image (Default-Portrait-2688h@3x.png).

      Additional note:
      Please fix the file names for the iPhone XR portrait and iPhone XR landscape under iOS graphic asset requirements and options in https://docs.axway.com/bundle/Titanium_SDK_allOS_en/page/icons_and_splash_screens.html as it currently states @3x when it should state @2x.

      Cheers,

      Tom

        Attachments

          Activity

            People

            • Assignee:
              hknoechel Hans Knöchel
              Reporter:
              tgiessel Tom Giessel
              Reviewer:
              Vijay Singh
              Tester:
              Samir Mohammed
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-6597
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code