Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26404

iOS: Cannot build hyperloop-examples app with Xcode 10 and 7.4.0 SDK

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 7.4.0
    • Fix Version/s: Release 7.4.1
    • Component/s: None
    • Labels:
    • Environment:

      7.4.0 GA SDK, 7.4.1 latest build, Xcode 10

    • Story Points:
      1
    • Sprint:
      2018 Sprint 19 SDK

      Description

      We've experienced this with an app that uses Hyperloop that builds fine under 7.3.1 SDK and Xcode 9 but the build fails under 7.4.0 (and latest build 7.4.1) SDK and Xcode 10.

      I duplicated the results with the latest hyperloop-examples app on Github so this impacts apps that use Hyperloop (perhaps in a non-trivial manner?).

      Basically, the build continues until it would normally say "Invoking xcodebuild" and instead outputs...

      [TRACE] : [Hyperloop] metabase took 3882 ms to generate
      2018-09-21T04:40:05.382Z | ERROR | An uncaught exception was thrown!
      Invalid Version: 12.-1.0
      2018-09-21T04:40:05.382Z | ERROR | Invalid Version: 12.-1.0

        Attachments

          Activity

            People

            • Assignee:
              eharris Ewan Harris
              Reporter:
              jfalcone Joe Falcone
              Reviewer:
              Hans Knöchel
              Tester:
              Samir Mohammed
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-6591
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code