Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26261

Android: Compile with SDK version 28 (Android P)

    Details

      Description

      Update "titanium_mobile/android" to compile for Android P (ie: "compileSdkVersion" 28).

      This is needed in order to use the newest API Level 28 features so that we can work on the "Android P" epic.

      Starting off, Titanium should not target API Level 28 by default until all Android P breaking changes have been resolved. But we should allow the developer to opt-in to targeting API Level 28 to test the newest features/changes.

        Attachments

          Activity

            People

            • Assignee:
              jquick Joshua Quick
              Reporter:
              jquick Joshua Quick
              Reviewer:
              Gary Mathews
            • Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Source Code