Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26180

Android: CLI does not provide useful information when a selected buildTools version is not installed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: Release 7.1.1, Release 7.2.0
    • Fix Version/s: Release 7.5.0
    • Component/s: Android, CLI
    • Labels:
    • Environment:

      SDK: 7.1.1.GA, 7.2.0.GA

    • Sprint:
      2018 Sprint 14 SDK

      Description

      Description

      In AC-5789, the android.buildTools.selectedVersion config setting was set to a version that was not installed, this then led to the CLI outputting a confusing error that the version was unsupported/missing required tools. This error could be improved to push an issue stating that the version set in the config is not installed, which can then be asserted in the build process.

      Steps to reproduce
      1. Run appc ti config android.buildTools.selectedVersion 22.0.1
      2. Run appc ti info
      Actual

      Everything looks like that version is installed

      Expected

      If a selected version is not installed, then we should make it move obvious

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                eharris Ewan Harris
                Reporter:
                eharris Ewan Harris
                Reviewer:
                Joshua Quick
              • Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-6439
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code