Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26153

CLI: Remove Node 4 & 6 as supported versions

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 8.0.0
    • Component/s: CLI
    • Labels:
      None

      Description

      We currently support 3 Node release lines in Titanium SDK,

      • 4.x - End of life'd in April 2018
      • 6.x - Will be end of life in April 2019
      • 8.x - Will be end of life in December 2019 (shorter LTS cycle to align with an OpenSSL deprecation)

      We'll be adding a fourth (10.x) before it goes LTS in October no doubt

      I propose that we reduce this number, definitely removing 4.x, and potentially removing 6.x to align with the appc cli/daemon requirements (which require 8)

      cc Hans Knöchel Rene Pot Christopher Williams

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                eharris Ewan Harris
                Reporter:
                eharris Ewan Harris
                Reviewer:
                Christopher Williams
                Tester:
                Lokesh Choudhary
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Source Code