Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26151

Ti.Platform.id not working on Android in 7.2.0.GA (works on 7.1.1.GA)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 7.2.0
    • Fix Version/s: Release 7.3.0
    • Component/s: Android
    • Environment:

      Testing on a Moto G5Plus Running Android 7.

    • Story Points:
      2
    • Sprint:
      2018 Sprint 13 SDK

      Description

      I just tried upgrading to Ti 7.2.0.GA and found that Ti.Platform.id is returning null on Android. It works when reverting back to 7.1.1.GA. And it works on iOS.

      When using 7.1.1.GA `alert(Ti.Platform.id);` returns a string (as expected).

      When using 7.2.0.GA `alert(Ti.Platform.id);` returns "null".

      Given 7.2.0 looks like it was mostly about GDPR, could it have been pulled out inadvertently? Or does the documentation need updating (http://docs.appcelerator.com/platform/latest/#!/api/Titanium.Platform-property-id)? Or am I missing something?

        Attachments

          Activity

            People

            • Assignee:
              ybanev Yordan Banev
              Reporter:
              raefa Raef Akehurst
              Tester:
              Samir Mohammed
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-6415
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code