Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-26066

node-ios-device: Support Xcode 9 and Node.js 10

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 7.3.0
    • Component/s: Tooling
    • Labels:
      None
    • Story Points:
      8
    • Sprint:
      2018 Sprint 11 Tooling

      Description

      Apparently newer versions of Xcode prohibit the linking to private frameworks. In the case of node-ios-device, it needs to link with MobileDevice.framework and can't with Xcode 9.2 and 9.3.

      node-pre-gyp is pretty out-of-date.

      The build scripts need to be updated for Node.js 10 (and Node.js 9).

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              cbarber Chris Barber
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Source Code