Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-25943

Windows: Unable to install to device with JDK 9

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 7.1.1
    • Fix Version/s: Release 7.1.1
    • Component/s: Windows, Windows phone
    • Labels:
      None
    • Environment:

      Windows 10 Pro (1709)
      Appc NPM: 4.2.13-2
      Appc SDK: 7.1.1.v20180405080421
      Hyperloop 3.0.4
      Appc CLI:7.0.3-master.28
      Node Ver: 8.9.1
      NPM Ver: 5.7.1
      JDK 9.0.4

    • Story Points:
      5
    • Sprint:
      2018 Sprint 08 SDK

      Description

      I am unable to install to a device with JDK 9 this is due to package.json.

      When I change the package.json to allow JDK 9 it installs to the device but the application crashes immediately with no error log.

      Actual

      [ERROR] :  JDK version 9.0.4 detected, but only version <=1.8.x is supported
      

      Expected

      No error is thrown.

        Attachments

          Activity

            People

            • Assignee:
              kiguchi Kota Iguchi
              Reporter:
              jlongton Josh Longton
              Reviewer:
              Lokesh Choudhary
              Tester:
              Samir Mohammed
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-6289
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code