Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-25393

Adding Third-Party iOS Framework causes build error with 6.2.x

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 6.3.0
    • Component/s: iOS
    • Labels:
    • Environment:

      MacOS Sierra with SDK 6.2.2.GA and 6.2.1.GA and Studio 4.10.0

      Description

      We're experimenting with integration of third-party libraries and frameworks with Hyperloop.

      We added the ContentfulAPI ObjC Framework to the app/platform/ios directory of the hyperloop_examples app. When we built the app with either SDK 6.2.1 or 6.2.2, we get this error late in the build process...

      2017-10-14T20:24:55.215Z | ERROR | An uncaught exception was thrown!
      (buildSettings.LD_RUNPATH_SEARCH_PATHS || "").replace is not a function
      2017-10-14T20:24:55.216Z | ERROR | (buildSettings.LD_RUNPATH_SEARCH_PATHS || "").replace is not a function

      When we remove the Framework, the build completes successfully.

      I've attached the log. This appears to be either a regression based on comments in other reports that this mechanism worked.

      Also, parenthetically, and the source of another JIRA report not yet filed - we did attempt to use the Contentful Pod and that also resulted in build errors. So at this point we're shall we say "stymied" with respect to integrating the Contentful SDK. We've also tried to do the same with the Flurry SDK and have also encountered problems.

        Attachments

          Activity

            People

            • Assignee:
              jvennemann Jan Vennemann
              Reporter:
              jfalcone Joe Falcone
              Reviewer:
              Chris Barber
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-5880
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code