Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-25385

Windows: Broken display text after 6.2.2.GA updated

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 6.2.2
    • Fix Version/s: Release 6.3.0
    • Component/s: Windows
    • Labels:
      None
    • Story Points:
      5
    • Sprint:
      2017 Sprint 21 SDK

      Description

      Hello,

      We have tested the issue on the following environment and the Label text under a TableView Row is not showing on 6.2.2.GA.
      Testing Environment:
      Operating System
      Name = Microsoft Windows 8.1 Pro
      Version = 6.3.9600
      Architecture = 32bit

      1. CPUs = 4
        Memory = 6323945472
        Node.js
        Node.js Version = 4.6.0
        npm Version = 2.15.9
        Titanium CLI
        CLI Version = 5.0.14
        Titanium SDK
        SDK Version = 6.2.2.GA
        Appcelerator Command-Line Interface, version 6.2.4
        Test Case:
        index.xml

        <Alloy>
         <Window class="container" layout="vertical">
         
          <Label id="label" >Hello, World</Label>
          <View layout="vertical" height="600">
           <TableView backgroundColor="red" separatorStyle="none" scrollable="false" left="2" right="2" top="2" bottom="2" selectionStyle="none">
            <TableViewRow layout="horizontal" backgroundColor="transparent" hasChild="true" selectedBackgroundColor="#666" width="100%" height="100%">
             <Label class="myLabel" left="10" color="white">HELLO WINDOW APP</Label>
            </TableViewRow>
           </TableView>
          </View>
         </Window>
        </Alloy>

        index.tss

        ".myLabel": {
         
        width: Ti.UI.SIZE,
         
        height: Ti.UI.SIZE,
         
        color: "#000",
         
        font : {
         
        fontSize : 40
         
        }
        }

        index.js

        $.index.open();

      Test Results:
      Broken display text after 6.2.2.GA updated
      Attached the output images for 6.1.1.GA and 6.2.2.GA

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kiguchi Kota Iguchi
                Reporter:
                fhaque Fazlul Haque
                Reviewer:
                Gary Mathews
                Tester:
                Ewan Harris
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-5872
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code