Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-25309

Xcode 9 / iPhone X: Simulator is killed everytime, app-session terminated

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 6.2.0
    • Fix Version/s: Release 6.3.0, ioslib 1.6.0
    • Component/s: iOS
    • Labels:
      None
    • Environment:

      Xcode 9 GM
      iPhone X
      iOS 11 GM

      Description

      This is similar to the one I reported earlier this year, related to iOS 11: When running an app for the iPhone X (maybe others as well, not tested so far), the build succeeds, the app is installed, but not launched. Instead, the CLI session is terminated and the console stops.

      Also, when deploying to the iPhone X simulator while it is already running, it get's killed and relaunched, after it fails launching again. This is not only a major UX regression, but also makes it impossible to debug any iOS app.

      I need to find the other ticket again, but it looks like the Sim-status indicates it is shutting down and therefore we kill it. Xcode 9 hopefully has a different signal-system to handle this.

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              hknoechel Hans Knöchel
              Reviewer:
              Hans Knöchel
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-11164
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code