Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-25044

Windows: touchEnabled: false wont work on Ti.UI.View

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 6.1.0
    • Fix Version/s: Release 6.2.0
    • Component/s: Windows
    • Environment:

      SDK 6.1.1.GA
      Microsoft Windows 10 Enterprise 2015 LTSB

    • Story Points:
      3
    • Sprint:
      2017 Sprint 16 SDK

      Description

      Steps to reproduce:

      1) Run the sample app project (can be a -T ws-local deploy)
      2) A blank screen with two red views will appear (the one on top has touchEnabled = true, the one on the bottom has touchEnabled = false).
      3) Click on both, observe the output in the alert (it prints e.source.id).

      As the Ti.UI.View on the bottom has touchEnabled = false in tss file, the alert should not print "touchEnabledFalseView".

        Attachments

        1. index.js
          0.1 kB
        2. index.tss
          0.3 kB
        3. index.xml
          0.1 kB

          Issue Links

            Activity

              People

              • Assignee:
                kiguchi Kota Iguchi (Inactive)
                Reporter:
                sliang Shuo Liang
                Reviewer:
                Gary Mathews
                Tester:
                Samir Mohammed
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-10949
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Integration