Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24956

Windowslib: Unable to get product guid

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Fixed
    • Affects Version/s: windowslib 0.4.30
    • Fix Version/s: Release 6.2.0
    • Component/s: Tooling, Windows
    • Labels:
      None
    • Environment:

      Windowslib 0.5.2

    • Story Points:
      5
    • Sprint:
      2017 Sprint 14 Tooling

      Description

      Description

      When filing a PR for TIMOB-24683, the unit tests were failing on Jenkins, they passed fine locally. It looked like the script that gets the app identity name to launch the app when installed to device was failing to unzip and then copy the appxmanifest file to the directory which would then cause the wptool launch call to error out due to an invalid guid.

      Steps to reproduce

      I am clueless as to how to reproduce this. That said to test the change didn't break anything we need to test building and launching to Windows 10 devices and emulator

      Actual

      Script fails to obtain the guid

      Expected

      Script should be able to get the guid

        Attachments

          Activity

            People

            • Assignee:
              eharris Ewan Harris
              Reporter:
              eharris Ewan Harris
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10887
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code