Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24712

Android: SDK 6.1.0.RC doesnt honor custom_theme.xml colorPrimary setting

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 6.1.0
    • Fix Version/s: Release 6.1.0
    • Component/s: Android
    • Labels:
    • Environment:

      Android 5.0.2. Appcelerator SDK 6.1.0.RC.

    • Sprint:
      2017 Sprint 11 SDK

      Description

      I have the following custom scheme.

      <?xml version="1.0" encoding="utf-8"?>
      <resources>
          <style name="tracker" parent="@style/Theme.AppCompat">
              <item name="colorPrimary">#0054a6</item>
              <item name="colorAccent">#FFFFFF</item>
              <item name="android:statusBarColor">#004486</item>
              <item name="android:navigationBarColor">#004486</item>
          </style>
          <style name="tracker.NoActionBar" parent="@style/Theme.AppCompat">
              <!-- AppCompat Compatibility -->
              <item name="windowActionBar">false</item>
              <item name="windowNoTitle">true</item>
          </style>
      </resources>
      

      On compiling under 6.1.0.RC I find that the colorPrimary (#0054a6) is no longer a nice blue, but an ugly gray. Go back to the previous version and it all works as expected.

        Attachments

          Activity

            People

            • Assignee:
              jquick Joshua Quick
              Reporter:
              greg@snapithd.com greg
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10702
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration