Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24634

(Windows) Unable to run a Windows application using the 6.1.0.v20170426072049 build

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 6.1.0
    • Component/s: Tooling
    • Labels:
      None
    • Environment:
    • Story Points:
      3
    • Sprint:
      2017 Sprint 09 SDK

      Description

      Using the latest 6.1.0 build (6.1.0.v20170426072049) I am unable to run any created applications to a Window Phone or Windows Emulator.

      Enter appc ti sdk install -b master -d in the appc CLI to get the latest build.

      Steps to reproduce:
      1. Open Appcelerator Studio
      2. Go to file -> New -> mobile app project
      3. Select a classic default project and press next
      4. Enter project name and app id
      5. Press finish to create the application
      6. Go to the tiapp.xml and change the SDK version to 6.1.0.v20170426072049
      7. Run the application to a device or emulator

      Expected result
      Application should run without any issues

      Actual result
      Following error is shown in the console:

      2017-04-26T17:21:53.379Z | ERROR  | An uncaught exception was thrown!
      Cannot find module 'node-titanium-sdk/lib/builder'
      2017-04-26T17:21:53.385Z | ERROR  | Cannot find module 'node-titanium-sdk/lib/builder'
      2017-04-26T17:21:53.385Z | TRACE  | Error: Cannot find module 'node-titanium-sdk/lib/builder'
          at Function.Module._resolveFilename (module.js:469:15)
          at Function.Module._load (module.js:417:25)
          at Module.require (module.js:497:17)
          at require (internal/module.js:20:19)
          at Object.<anonymous> (C:\ProgramData\Titanium\mobilesdk\win32\6.1.0.v20170426072049\windows\cli\commands\_build.js:14:15)
          at Module._compile (module.js:570:32)
          at Object.Module._extensions..js (module.js:579:10)
          at Module.load (module.js:487:32)
          at tryModuleLoad (module.js:446:12)
          at Function.Module._load (module.js:438:3)
          at Module.require (module.js:497:17)
          at require (internal/module.js:20:19)
          at C:\ProgramData\Titanium\mobilesdk\win32\6.1.0.v20170426072049\node_modules\titanium-sdk\lib\titanium.js:86:14
          at C:\ProgramData\Titanium\mobilesdk\win32\6.1.0.v20170426072049\node_modules\async\dist\async.js:3816:26
          at eachOfArrayLike (C:\ProgramData\Titanium\mobilesdk\win32\6.1.0.v20170426072049\node_modules\async\dist\async.js:1039:9)
          at eachOf (C:\ProgramData\Titanium\mobilesdk\win32\6.1.0.v20170426072049\node_modules\async\dist\async.js:1087:5)
      

      Using a previous SDK build (6.1.0.v20170421082637) the application runs without any issues.

        Attachments

          Activity

            People

            • Assignee:
              cwilliams Christopher Williams
              Reporter:
              smohammed Samir Mohammed
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10636
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration