Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24533

Windows: WebView does not set html property

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 6.1.0
    • Fix Version/s: Release 6.2.0
    • Component/s: Windows
    • Labels:
    • Environment:
    • Sprint:
      2017 Sprint 11 SDK

      Description

      On the Windows platform the WebView ui component does not set the html property when loading web pages. This makes interacting with web pages impossible.

      Sample index.js (tested with SDK 6.0.2.GA):

      $.index.open();
      $.webview.setUrl("http://www.perfecthomecomputers.co.uk");
      $.webview.addEventListener('load',function(e) {
      setTimeout( function()

      { Ti.API.info("> HTML: "+$.webview.getHtml()); $.label.text = "HTML: " + $.webview.getHtml(); }

      , 10000);
      });

      The timeout was only put there just in case the html attribute became populated after the load event fired.

      Sample project can be downloaded from: https://github.com/DesHuth/titanium-test

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                kiguchi Kota Iguchi (Inactive)
                Reporter:
                deshuth Derrick Huth
                Reviewer:
                Gary Mathews
                Tester:
                Samir Mohammed
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Titanium SDK/CLI <> Titanium Mobile
                    Synced with:
                    TIMOB-10569
                    Sync status:
                    ERROR
                    Last received:
                    Last sent:

                    Git Source Code