Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24394

iOS: "Unable to locate iOS Package Application tool" using Xcode 8.3 for device builds

    Details

    • Type: Bug
    • Status: Closed
    • Priority: None
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 6.0.2
    • Component/s: iOS
    • Labels:
    • Sprint:
      2017 Sprint 04 Tooling

      Description

      When building for device using Xcode 8.3 Beta, the following warning is logged before iTunes is opened (and the app shows up there):

      [TRACE] ** BUILD SUCCEEDED **
      [INFO]  Finished building the application in 1m 23s 176ms
      [WARN]  Unable to locate iOS Package Application tool
      [INFO]  Installing application into iTunes
      [INFO]  Initiating iTunes sync
      

      To reproduce:
      1. Create a new project: appc new -p ios
      2. Run the project on the device, but don't attach a device: appc run -p ios -T device

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              hknoechel Hans Knöchel
              Reviewer:
              Hans Knöchel
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10483
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code