Ti.App.Properties currently has a load of bloat functions which do not add anything but confusion.
I suggest using a plain function like:
`Ti.App.Properties.get('myKey');` (will then return either an object/array/string/number, depending on what you've set).
And discard all functions like `setList`, `setObject`, `setString`, `getList`, `getObject`, `getString`.
Also instead of having `Ti.App.Properties.removeAllProperties()`, we should aim for a concise naming like `Ti.App.Properties.clear()`. We are already in the Properties namespace so no need to repeat it in any of it's functions.