Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24171

iOS: AccessibilityLabel or AccessibilityValue does not work.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: titanium 5.0.9, Release 8.0.2
    • Fix Version/s: Release 8.2.0
    • Component/s: iOS
    • Environment:
    • Story Points:
      5
    • Sprint:
      2019 Sprint 17, 2019 Sprint 18

      Description

      If you create an ImageView in an xml file and then in the controller try to set accessibilityLabel or accessibilityValue it will not take effect. You can verify this with my example code attached and run the app with Accessibility Inspector turned on. You can click on the text and see the accessibility label being set, but not the ImageView. This is affecting our ability to run automated tests using the accessibility information.

        Attachments

          Activity

            People

            • Assignee:
              vijaysingh Vijay Singh
              Reporter:
              cthomas Christy Thomas
              Reviewer:
              Jan Vennemann
              Tester:
              Satyam Sekhri
            • Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10301
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code