Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24144

iOS: Modules with apiversion 3 will fail on Titanium 6.0.0 (Regression)

    Details

    • Sprint:
      2016 Sprint 24 SDK

      Description

      While testing our pre-GA version with some of my bigger apps, I noticed that the build will fail if one of my modules has the apiversion set to 3 in the iOS manifest (not Android). Did we ever propose to bump this version, e.g. while updating to 64 bit architecture?

      This does not fail on Titanium SDK < 6.0.0, e.g. 5.5.1.GA, so it's a regression or at least change of behavior. I guess it's caused by a CLI change that checks something for our Android modules.

      So at least, we should print a better error than just:

      [ERROR] Found incompatible Titanium Modules:
      [ERROR]    id: com.widbook.brightness	 version: 1.0.1	 platform: ios,iphone	 min sdk: 3.1.0.GA
       

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              hknoechel Hans Knöchel
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10280
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration