Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-24028

iOS: Build errors out with Invalid <log-server-port> found in the tiapp.xml: undefined

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 6.0.0
    • Fix Version/s: Release 6.0.0
    • Component/s: iOS
    • Labels:
    • Environment:

      OS: Mac OS X 10.11.6
      Appc core: 6.0.0-58
      Appc NPM: 4.2.8-7
      Ti SDK: 6.0.0.v20161013032040
      Appc Studio: 4.8.0.201609191928
      Node: 4.5.0
      NPM: 2.15.9

    • Story Points:
      1

      Description

      Description

      When building a project for iOS device or simulator the build will fail with the following [ERROR] Invalid <log-server-port> found in the tiapp.xml: undefined, this happens when building for device or simulator.

      Workaround

      Add <log-server-port>12345</log-server-port> to the iOS section of your tiapp

      Steps to reproduce
      1. Create an app using appc new/ti create
      2. Build the app for iOS using appc run -p ios/ti build -p ios
      Actual result

      Build errors out with the above

      Expected result

      Build should not error out

        Attachments

          Activity

            People

            • Assignee:
              cbarber Chris Barber
              Reporter:
              eharris Ewan Harris
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-10200
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Source Code