Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-23817

CLI: Update upper limit for node version in vendorDependencies

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Release 6.0.0, Release 6.1.0
    • Fix Version/s: Release 6.0.0
    • Component/s: CLI
    • Labels:
    • Environment:

      Windows 10 Pro
      Ti SDK: 6.0.0.v20160823163945, 6.1.0.v20160823210524

    • Sprint:
      2016 Sprint 18 Tooling

      Description

      Description

      As per Chris on flowdock, 5.x has ben EOL'd, we should not tell a user to install it, like below when running SDK 6.0.0 or 6.1.0 with Node 0.12.7

      ERROR] Titanium SDK 6.0.0.v20160823163945 is incompatible with Node.js v0.12.7
       
      You will need to install Node.js v5 in order to use this version of the Titanium SDK.
      

      cbarber
      @team, io.js (all versions) and Node.js 5.x has been end of life'd today... only Node.js 4.x and 6.x is supported and will receive fixes/backports
      

      Steps to reproduce
      1. Install Node 0.12.7 and either a 6_0_X or master branch SDK
      2. Try to run a titanium command such as appc ti info
      Actual result

      The command will error as you are using a version lower than supported, you are told to install v5

      Expected result

      The command will error as you are using a version lower than supported, you should be told to install a supported version of Node

        Attachments

          Activity

            People

            • Assignee:
              fmiao Feon Sua Xin Miao
              Reporter:
              eharris Ewan Harris
              Reviewer:
              Chris Barber
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Source Code